Input your search keywords and press Enter.

(NCSC) issues a high-risk warning about updating “Google Chrome”

The National Cyber ​​Security Advisory Center (NCSC) has issued a new, high-risk warning about a security update in the Google Chrome browser.

Through its official “Twitter” account, it has explained that “Google” has updated the “Chrome” browser for Mac and Windows computers to address a range of vulnerabilities.

It warned that an attacker could exploit vulnerabilities to reveal and disclose information, and execute malicious software.

It is recommended to update the browser to version 94.0.4606.71; as Google has released an explanation of the necessary update, which can be found here.

The Guidance Center indicated to “Cyber ​​Security”, that the method of updating is by following the following steps:

Open Chrome.

At the top left of the screen, click on “More” Help “About Google Chrome”.

The current version number is the set of numbers below the word “Google Chrome.”

Chrome will check for updates and auto-update

– Click on Restart.

Short link :
close

Hi there 👋

Sign up to receive awesome content in your inbox, every month.

We don’t spam! Read our privacy policy for more info.